Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Errors Loading Smartsheet

Incident Report for Smartsheet AU

Postmortem

At 4:40pm PST on February 3rd, 2026, our engineers identified errors when accessing certain pages in the application, such as sheets and browse. A fix was identified and we observed gradual recovery.  We returned to normal operation at 7:35pm PST.

Posted Feb 04, 2026 - 17:25 UTC

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 05:39 UTC

Monitoring

A fix has been implemented and we are monitoring to ensure continued stability.
Posted Feb 04, 2026 - 03:37 UTC

Identified

The issue has been identified and a fix is being implemented. We will continue to post frequent updates.
Posted Feb 04, 2026 - 02:43 UTC

Investigating

A new issue has been discovered and is being investigated. Symptoms remain unchanged. We will continue to provide frequent updates.
Posted Feb 04, 2026 - 02:18 UTC

Update

We are continuing to implement the fix. We will continue to post frequent updates.
Posted Feb 04, 2026 - 01:48 UTC

Identified

The issue has been identified and a fix is being implemented. We will continue to post frequent updates.
Posted Feb 04, 2026 - 01:13 UTC

Investigating

We are currently investigating generic errors for users attempting to access certain pages and views. Sheets can still be loaded in New Views (Table, Board, Timeline). We are continuing to investigate and will post frequent updates.
Posted Feb 04, 2026 - 01:04 UTC
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Forms, Reports, Dashboards) and Documents (Attachments).